OT BioLab

UserManual v3.4
for software version 2.0.6771.0
1

Sommario
1

Introduction .................................................................................................. 3

2

OT BioLab installation .................................................................................... 4

3

Driver installation ........................................................................................... 8

4

Signal Acquisition ......................................................................................... 10

5

6

4.1

Setting the acquisition parameters .......................................................... 10

4.2

Creating a setup .................................................................................... 11

4.3

Entering Visualization Mode .................................................................... 13

4.4

Storing signals and accessory parameters ............................................... 14

4.5

Track options ........................................................................................ 16

4.6

Feedback window .................................................................................. 18

4.7

Display window ..................................................................................... 21

Signal Review .............................................................................................. 26
5.1

File extensions ....................................................................................... 26

5.2

Reviewing a signal ................................................................................. 27

5.3

Signal Export ......................................................................................... 30

Signal Processing ......................................................................................... 33
6.1

Amplitude.............................................................................................. 33

6.2

Data Approximation ............................................................................... 34

6.3

Calibration ............................................................................................. 34

6.4

User Code ............................................................................................. 34

6.5

Conduction Velocity Estimation ............................................................... 34

2

1 Introduction
OT BioLab is an acquisition and processing tool developed by OT Bioelettronica. It is a freeware software
downloadable at www.otbioelettronica.it in the Download section.
A flash version of the manual is also available at OT Bioelettronica web site. OT BioLab allows to acquire,
review and process bioelectrical signals detected using the OT Bioelettronica devices listed below:
QUATTRO: a surface EMG data logger that can record up to 37 hours continuously the activity of four
different muscles.
MEBA: surface and intramuscular electromyographic amplifier, up to 32 channels
TRENTADUE: a surface EMG device that can transmit wireless 32 channels @ 2 kHz to a PC
EMG-USB: surface electromyographic amplifier, up to 128 channels
EMG-USB2: surface and intramuscular electromyographic amplifier, up to 256 channels
EMG-USB2+: surface and intramuscular electromyographic amplifier, up to 256 channels. Each input
can acquire signals with a different acquisition mode.
QUATTROCENTO: surface and intramuscular electromyographic amplifier, up to 400 channels.
P-ForceMet: single channel force amplifier and biofeedback
Bruxoff: three channels (2 EMG + 1 ECG) datalogger
µEMG: single channel EMG datalogger
Using OT BioLab it is also possible to review and process any kind of signals stored in txt format.
OT BioLab has been designed for Windows XP, Windows Vista, Windows 7, Windows 8, Windows 8.1
and Windows 10 operating both with 32 or 64 bit.
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2 OT BioLab installation
OT BioLab installation procedure requires few minutes and allows to install the software and preinstall
the drivers for EMG-USB2, MEBA, SHAKEEG and EMG-USB. Extract and run the OT BioLab setup file.
The start-up window will appear (see Fig. 2.1), click “Next” to continue.

FIG. 2.1. OT BioLab installation start-up window.
Now, the license agreement window appears (see Fig. 2.2). Read carefully the license condition and
click “Next” to continue.

FIG. 2.2. OT BioLab license agreement window.
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The next step require to choose the folder where the program will be installed. It is possible to browse
the PC and select the desired folder (see Fig. 2.3). Again, click “Next” to proceed.

Fig. 2.3. OT BioLab folder installation selection.
It is possible to create a shortcut in the Start Menu folder (see Fig. 2.4).

Fig. 2.4. Shortcut in the Start Menu folder.
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Now the software is ready to be installed (see Fig.2.5).

Fig. 2.5. OT BioLab installation window.
Installing OT BioLab it is also possible to pre-install the drivers (see Fig. 2.6, 2.7, 2.8).

Fig. 2.6. OT BioLab drivers pre-installation window.
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Fig. 2.7.OT BioLab drivers pre-installation window.

Fig. 2.8. OT BioLab drivers pre-installation window.
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3 Driver installation
The installation of new drivers can be completed by connecting any OT Bioelettronica device, equipped
with a USB port, to the PC. When a device is connected to the PC the full drivers installation
automatically starts (see Fig. 3.1).

Fig. 3.1. New hardware installation window.

The messages appearing in the following windows will be displayed in the language of the operative
system. In this manual the figures show the windows visualized by the Italian operative system.
In the first window of the procedure select “Not now” from the options list and then click
“Next” to proceed. The driver pre-installation performed during OT BioLab installation allows to choose
the option “Install automatically” in the second window of the procedure.
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Fig. 3.2. Drivers install option.

Figure 3.3 shows the last window displayed at the end of the drivers installation procedure.

Fig. 3.3. Window displayed at the end of drivers installation procedure.
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4 Signal Acquisition
Follow
a)
b)
c)
d)

the next steps to perform a signal acquisition using OT BioLab:
Set the acquisition parameters
Create a setup
Enter in the signal visualization mode
Start the acquisition and store all the accessory information

4.1 Setting the acquisition parameters
The acquisition parameters can be set selecting: Tool -> Options from the OT BioLab main menu (see
Fig. 4.1).

Fig. 4.1. Options window, it allows to set the acquisition parameters.

The option window allows choosing different parameters listed below:
Device: it sets the device that will be used to acquire the signals. Available options are: EMG-USB,
EMG-USB2, MEBA or SHAKEEG.
Channels: it selects the number of channels that will be transferred between the device and
the PC. This number can be lower than the physical channels provided by the device connected
to the PC; moreover, possible options are different for different devices. This number
representsthe number of channels that will be transferred to the PC. Consider that when a
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large number of channels is transferred, the PC workload increase. Note:the number of saved
channels can be lower than the transferred channels. Additionally to the selected channels, the
devices transfer to PC also the auxiliary (AUX-IN) channels. In particular, 8 auxiliary channels
are transferred when using the EMG-USB or MEBA, 16 channels when using the EMG-USB2
and 4 channels when using SHAKEEG.
Sampling frequency: it sets the signals sampling rate. Available values are different for different
devices. When high sampling frequency is used could be useful to reduce the number of
channels transferred to the PC to reduce the PC workload.
Data Acquisition Path Folder: it sets the path folder of the acquired data. As default the path
folder is C:\Users\USER\Documentsbut it can be changed by the browse folder button. In this
folder the acquired data will be finally saved.

4.2 Creating a setup
From the toolbar menu, in the main window, select Acquisition -> Setup editor to open the Setup
window. The Setup window allows building a setup (see Fig. 4.2).

Fig. 4.2. The Setup editor allows create a measurement setup.

The channel table is displayed in the left side of the Setup window. The table number of rows reflects
the transferred channels between the selected device and the PC. Each row represents a physical
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channel of the amplifier (the number of transferred channels and the device can be set in the Options
window). The first table column indicates the inputs associated to each channel. The different inputs
are highlighted alternating the background colour.
The last rows of this table (8 rows for EMG-USB and MEBA, 16 rows for EMG-USB2and EMG-USB2) are
devoted to the AUX-IN channels.
In the right side of the Setup window, a series of buttons and drop down menu give the possibility to
build the setup
From top to bottom the drop down menus allow the user to:
-

select the sensor type

-

select the adapter type

-

select the muscle where the sensor is applied

-

select the side.

Pictures of sensors and of adapters help the user to insert the correct setup. For each sensor, one or
more adapters are available.
There are different types of sensors and they are divided in five groups: AUX, EEG, iEMG, MMG, sEMG.
Restrictions are applied on the AUX sensors; they can only be associated to the AUX IN channels. All
the other channels can be assigned to any other sensor type, is up to the user to know which amplifier
channels can be used to manage a certain signal type.
The software has been mainly designed for the acquisition and manipulation of EMG signals. For this
reason it is compulsory to associate a muscle for each channel. In case of
AUX in or EEG signals it is possible to select the “Not a Muscle” menu voice and the side can be left
undeclared.
Many of the available sensors can detect more than one signal (e.g. an EMG electrode array). Each
signal is amplified by an amplifier channel. When a sensor is inserted in the setup, the correct number
of channels is automatically occupied by the sensor.
The buttons on the right side of the Setup Editor window allow the user to:
- insert a sensor (with associated muscle and side) into the selected line of the table, all the
necessary subsequent rows (i.e. channels of the amplifier) will be associated and occupied by
the sensor;
- replicate the sensor different times in case more sensors of the same type have to be inserted;
- delete only the sensor associated to the selected row of the table;
- clear all channels of the table;
- load a previously defined setup
- save the current setup
- complete the setup and use the current setup for acquisition even if it has not saved.
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Please note that only the channels associated to a sensor will be stored on the PC during an acquisition.
This means that it is possible to acquire just the channels needed between the channels transferred to
the PC through the USB.
Two additional columns in the channels table, available only for the AUX-IN channels, give to the user
the possibility to display the values of desired channels in a pop-up window, or to use the desired
channels as biofeedback. Refer to Feedback Window and Display Window sections for further details.
Finally a Warning Checkbox can be selected in the bottom of the Setup Editor (see Fig.13). If it is
checked as “Warning Enabled”, it allows show a window warning in case the sensor selected with the
corresponding adapter and the acquisition mode is not correct for the setup chosen. The warning
guides the user to select the right configuration. Only in this case the acquisition will not start until the
correct configuration is used of when the checkbox will be set to “Warning Disabled”.
As default the checkbox is set to “Warning Disabled”.

Please note that different electrodes require different acquisition mode:
1. If you are using couples of electrodes, use bipolar acquisition.
2. If you are using arrays, use differential acquisition.
3. If you are using matrices, use monopolar acquisition.

4.3 Entering Visualization Mode
OT BioLab has two different working modes: Review Mode and Visualization Mode. The Review Mode
allows to review and process signals previously acquired; the Visualization Mode can be used when
an external device is connected to the PC through a USB port to display in real time signals detected
from the device and to store them. By default OT BioLab is in Review Mode.

Fig. 4.3.Control toolbar for signal displaying and acquisition.
Once the acquisition parameters have been set and the setup has been created it is possible to switch
from Review Mode to Visualization Mode and display signals in real time by pressing the blue arrow
on the toolbar or selecting from the main menu: Acquisition -> Visualization. The signals are
automatically updated on the screen every second by displaying the data received from the USB port.
Different buttons are available in the toolbar in Visualization Mode(see Fig. 4.3), all the function listed
here are also available under the drop-down menu “Acquisition”:
•

Visualization: it allows to switch from Review Mode to Visualization Mode.

•

Review: it allows to switch from Visualization Mode to Review Mode.
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•

Freeze: during the visualization of the signal in real time it is possible to freeze signals
currently displayed on the screen, for example for a visual analysis. This button has no effect
on the signal stored if itis pressed during acquisition.

•

Restart: when in the freeze phase, this button restarts the visualization of the real time
signals.

•

Start Acquisition: this button starts the data storing of all signals associated to a sensor in the
setup in the PC hard drive.

•

Stop Acquisition: when the acquisition is in progress, this button can be used to stop the data
storing and to close the file.

•

Reset Saturation: each sensor has an indicator that changes from green to red when one of
the sensor signals is close to saturation (refer to the Advanced option in Visualization Mode
section). This button can be used to turn off the indicator.

Additional controls available in the toolbar:
•

Time scale: this drop down menu let the user to select the timescale used to display the
signals. There are 5 different options: 10 ms, 50 ms, 100 ms (default value), 1 s, 10 s. The
time value selected represents the whole displaying area horizontal size. Note that in case 10
ms, 50 ms or 100 ms are selected, since the software updates signals every 1 s, only a portion
of signals is displayed.

•

End acquisition in: this check box allows to pre-define the duration of an acquisition. When it
is selected, and a given number of seconds is indicated in the adjacent box, the acquisition
automatically stops when the desired time is elapsed.

•

Acquisition Time: it is an indicator that reports the acquisition time. The counter starts when
the Start Acquisition button is pressed.

4.4 Storing signals and accessory parameters
At the end of every acquisition, the Acquisition Parameters window is displayed (see Fig. 4.4). This
window summarizes all the setup information and, additionally, shows the data received from the
hardware device connected to the USB reporting gains, mode and cut off frequencies, used during the
acquisition, for each sensor.
Additional fields can be filled by the user to keep accessory information (e.g. the level contraction, the
MVC value, channels used as feedback) or comments about the signals acquired.
Finally, the button Keep Acquisition allows store data on the PC, while the button Discard Acquisition
let the user to discard the data acquired.
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Fig 4.4. Acquisition parameters window. It is displayed at the end of every acquisition and
summarizes the parameters related to the acquisition.
It is possible to proceed with signal file storing when the Keep acquisition button is pressed. Next steps
require to choose the subject from the database, write the place and the protocol name (See Fig. 4.5).
In case the subject has not been previously inserted into the database, pressing the Choose Subject
button it is possible to have complete access to the database and to introduce a new subject (refer to

Subject Toolbar section).
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Fig 4.5. Subject window. It is displayed at the end of every acquisition, after the user confirms the
choice to keep the signals acquired.
When all the fields have been filled, the OK button becomes available and it is possible to proceed to
the data storing.
The last window of the storing process asks the user to save the file in the folder previously selected
in the Tools ->Options Menu suggesting a file name for the .otb files. The file name is an 18 character
string in the format AANNSSPPYYMMDDMMSS.otb composed by:
•

two digits representing the amplifier identifier (AA)

•

first 2 letters of First name (NN)

•

first 2 letters of Family name (SS)

•

first 2 letters of Place (PP)

•

date: Year, Month and Day (YYMMDD)

•

time: Minutes and Seconds (MMSS)

The filename coded in this way ensure the unique name for any acquired file and allows the user with
practice to recognize the files. In order to save the file after long acquisition times two different types
of files can be saved in OT Biolab. In case the raw file dimension is lower than 400 MBytes, a single
file .otb will be saved, otherwise a folder will be saved in the same folder selected in the Tools->Options

Menu with the same name of the .otb file. In this folder three files will be saved:1) the raw file (i.e.
the binary data file) named with the 18 character string with extension .sig, 2) an .xml file named with
the 18 character string and 3) the abstract.xml file. These last two files contain all the information
about the recording. The .xml named with the 18 character string can be used to open the recording
in OT BioLab. The abstract.xml includes internal parameters and processing options transparent to the
user.

4.5 Track options
When running in visualization mode, OT BioLab displays a window similar to Fig. 4.6. Every sensor
inserted into the measurement setup (refer to Creating a Setup section) generate a track in the
visualization window. The tracks are composed by a sensor name area, a vertical scale area and a
signal display area. A track can be single track, in case the sensor is associated to one signal, or a
multiple track, when the sensor is associated to two or more signals. Each track can be hided or
displayed by using the Reduce/Expand button in the sensor name area. Moreover, all the tracks can
by hided or displayed at the same time using the Reduce/Expand button on the left upper corner of
the visualization area.
The vertical size of a track can be modified simply by moving the cursor close to the track upper or
lower border line, keep left mouse button pressed and move the border up or down.
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Fig 4.6. OT Biolab screenshot during signal visualization.
Few parts of the screen has been highlighted:
A. Reduce/Expand button.
B. Saturation indicator.
C. Sensor name area.
D. Vertical scale area.
E. Signal display area.
F. Amplitude values.
G. Time scale area.
The vertical scale area shows directly the signal amplitude in V at the end of the amplification chain
for single tracks, the enumeration of the signals associated to a sensor for multiple tracks. The
signals amplitude for multiple tracks can be indirectly estimated by using the signal baseline
distance as reference. Moving the cursor on the signal display area, the signals amplitude values
appears beside to the cursor. Moving the cursor on the sensor display area, some information
related to track will be displayed beside the cursor.
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H.
Every single or multiple track has an own saturation indicator. It is normally green and becomes red
when the signal (or one of the signals) is close to the saturation level (± 2.5 V for almost all amplifiers).
The indication can be intended as a suggestion to reduce the gain for the sensor. The indicator can be
reset, changing the colour from red to green, using the Reset Saturation button (refer to the Entering

Visualization Mode section).
Each sensor has different option that it is possible to access by right click in the sensor name area.
The sensor’s options in Visualization Mode are:
•

Set Vertical Range: selecting this option a new window will appear. The window is different
for single and multiple tracks. For single track it is possible to insert the minimum and
maximum values for the vertical scale. For multiple tracks it is possible to set the offset
between two adjacent channel or superimpose the signals (everyone will have the same
baseline) and set the minimum and maximum values for the vertical scale, as for the single
tracks.

•

Set Name: it is possible to change the sensor name.

•

Set Comments: it is possible to add comments for a given sensor.

•

Hide/Show last channel: only for multiple tracks, this option allows to hide the last signal
of a sensor (e.g. the last signals from an EMG array when differential mode is used).

•

Change Colour: this option allows to change the track colour. By default the signals are
black, the processing results are blue and the fitting curves are red (refer to the Signal

Processing section).
At the bottom of the left control window two buttons (+ or -) allows change the values of the signal
offset in case signals are grouped or to change the signal range in case are ungrouped.
Some option can be applied to more than one track at the same time. It can be done by selecting the
desired tracks: left click on the sensor name area or CTRL + left click to add additional tracks to
selection. All the tracks in a range can be selected: select the first desired track and then SHIFT + left
click on the last desired track. When a group of tracks is selected, changing one of the options: Set

Vertical Range, Change Colour or change the vertical track size, will be applied to the entire group of
selected tracks. In the upper right side of the toolbar (see Fig. 14) a “Free Selection” checkbox allows
to freely select parts of the signals with a start and end out of the epoch grid. When the “Free Selection”
is selected, in the “Start Time” and “End Time” boxes it is also possible to choose the start and the
end times of the signal to analyse.

4.6 Feedback window
OT BioLab features a real time visual feedback that can be used as a biofeedback during signals
acquisition. Using this tool it is possible to visualize two channels, or their average, as a biofeedback.
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The feedback tool has been designed to be used together with external signals, generated by torque,
force, or angle transducers, at the auxiliary inputs of the EMG-USB, EMG-USB2 and MEBA amplifiers
(refer to the instruments manuals for details).
The channels devoted as biofeedback can be selected in the Setup Editor window, between the
available AUX-IN channels, by checking the column Feedback. A maximum of two channels can be
assigned to the Biofeedback.

Fig 4.7.Feedback windows.
The feedback windows displays in real time signals of one or two AUX IN channels as vertical bars.
The feedback window can be moved in any part of the screen and can be placed in the extension of
the desktop shown on a second monitor placed in front of the subject.
The feedback graph (Fig. 4.7) reported as a vertical bar represents the real time value of the AUX-IN
channel, or the mean of two channels, selected. The bar is blue when the signal level is lower than
the target limits, is red when the signal level is greater than the target limits and is green when the
signal level is in between the target limits.
In the left side of the Feedback window some controls are available (Fig. 4.8):
Mode drop down selector. Select the operation mode: if the Absolute mode is chosen, the feedback
graph shows the raw input signal value. If the Relative mode is selected, the feedback graph shows
the value of the input signal as a percentage of the current MVC.
Target Value box. This box is used to select the target level. In Absolute mode the value is assumed
with the measurement unit selected (see section 10.4). In relative mode, the level is defined as a
percentage of the MVC value. In relative mode, the feedback full scale is automatically changed when
the target levels are lower than 45% MVC to maximize the graph resolution.
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Offset Null button. This button set the zero value by subtracting the amount of offset detected when
the button is press. The associated box shows the amount of offset subtracted in the selected
measurement units (see section 10.7). Please note that the offset is removed by software, changing
the saturation level of the feedback graph.
In the Feedback window left upper corner the red button starts Maximum Voluntary Contraction (MVC)
recording button and the Setup button open the Feedback Setup window.
By clicking the Start MCV Recording button, for 10 s the software will look for the highest value at
the input of the AUX-IN channel used as biofeedback. During the recording the warning “Recording
MVC” blinks.
The feedback configuration window allows the user to set the biofeedback parameters as desired. In
particular, it is possible to set:
Range. This values indicate the biofeedback vertical visualization limits.
Conversion factor. Is the sensibility at the AUX-IN input, for example a value of 40, when a force
transducer is used, indicate that a signal with an amplitude of 1 V at the AUX-IN input correspond to
40 kg of force applied to the sensor.
Measurement unit. Is the indication that will be used for the vertical axis.
Accuracy. Is the precision requested to the subject when holding a target level indicated as a
percentage of the full scale by two horizontals lines in the feedback graph.
Consider the average of the signals. When two channels are selected for the biofeedback, check
this box to visualize the average of the two channels as a single bar or uncheck the box to display
them independently.
Invert signal from channel X. For both feedback channels it is possible to invert the signal polarity
by checking the corresponding check box.

Fig 4.8. Feedback configuration window.
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Feedback setup form is opened by clicking on the Feedback setting item in the config menu. In this
window it is possible to configure the feedback parameters. Refer to text for further details.

4.7 Display window
For each AUX-IN channel it is possible to open a pop-up window displaying information about the
channel input signal. A display window can be assigned to an AUX-IN channel using the set-up editor.
A display window is automatically opened when starting the signals visualization for each AUX-IN
channel that has the checkbox in the Display column marked.

Fig 4.9. Display window.
This window displays, for a given channel, the current value, the minimum, the maximum, average
and offset value detected in the current section. This tool can be useful for sensors calibration.
The Display window shows information about a signal at the AUX-IN channel input. The current value,
the minimum and maximum detected, the average from the beginning of the session and the offset
are displayed in Volts (See Fig. 4.9).
In the left side of the display window the following controls are available:
Remove Offset. Allows subtract by software the data value reported in the display. When this button
is clicked the value of the offset subtracted to the real time data will been reported in the right bottom
of the display window. If this button is clicked two times, the offset value is reported to zero.
Reset. This button resets and set to zero the minimum, maximum and the average value data during
an acquisition.
Edit Preferences. With this button it is possible to open a new window in order to select a different
unit of measurements and the conversion factor between the old and the new units (see Fig 4.10).
Finally the new display window with the new units will be modified and displayed.
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Fig. 4.10.Feedback Setup.
This window displays the conversion factor and the units that can be changed during the visualization
of the AUX signals. After setting the new values the display window is modified and the units as example
are reported in “kg” as showed in the figure below.

4.8 Trapezoidal Feedback
Trapezoidal Feedback is a special feedback introduced in order to let the user to follow specific paths
during performance.
It is affordable only on one AUX channel and must be configured as follows.
Enable the Trapezoidal Feedback.
In order to enable it, go on Tools > Trapezoidal Path and enable it.
Then, in Setup Editor, flag the Checkbox Feedback available for the AUX channel of interest.
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Fig. 4.11. Enable Trapezoidal Feedback.

Once Setup Editor has been completed and trapezoidal feedback enabled, when acquisition is started
a path like this is shown.
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Fig. 4.12. Trapezoidal Feedback.

Configuration of Trapezoidal Feedback
Clicking on Settings, you can access to settings of the path.
•

Target error: the percentage of error shown on the path.

•

Reverse: if the value of the signal cell is negative, then flag this checkbox in order to make it
positive.

•

Bar feedback: a bar shown on the side.

•

Time: the duration in seconds of that section.

•

Hold: Value that must be held in that section.

•

Oscillation: number of oscillations in the section.

•

Amplitude: amplitude of the oscillation.

•

Conversion factor: value that will convert the received value in Volt in the amplitude requested.

•

Conversion Unit: unit of measurement of conversion.
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Fig. 4.13. Trapezoidal Feedback Settings.

How to use Trapezoidal Feedback
After settings have been done correctly, trapezoidal form will show the selected path.
•

Offset: clicking on offset, the instant value will be set as offset and removed from the plot.
Clicking again offset, Offset value will return to 0.

•

Rec MVC: this button will start an emg recording and will record the maximum value. The
maximum value will be stored and shown and all next values will be the ratio between received
data and MVC. MVC can be also be set manually.

•

Reset trace will reset the position of marker. It will start again from the beginning of the path.

In order to record data, please start recording from the main form of OT Biolab.
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5 Signal Review
OT BioLab allows to open and review different file types. There are two methods to load a file: using
the Open function under the File menu or from the Menu toolbar, or using the Import function under
the same menu and toolbar. The Open method simply open a new file and, in case other signals are
currently opened, they will be closed (if they are not saved a prompt will ask the user if the user want
to save them). The Import method keep the currently opened signals and adds the new ones under
them. The Import function can be particularly useful, for example, when signals recorded using more
µEMG-S devices have to be managed.

5.1 File extensions
OT Biolab can manage different kind of files:
•

Otb: files created by OT BioLab containing acquired signals, setup details, subject information,
processing data and workspace. This format will be used only if the raw data dimension is
smaller than 400 Mbytes. In case the RAM of the PC is not sufficient to save this amount of
data, the files can be recovered because saved in.xml format (see below) in the same path
previously chosen, in a folder named “temp”; otherwise the files are saved in the .otb format
and the “temp” folder will be deleted automatically.

•

Xml:
o

If the file data is larger than 400 Mbytes, due to large acquisition times, a message at
the end of the acquisition will inform the user that the file has been saved in a different
folder (see Fig. 5.1). This folder, as reported in Section 4.2, will contain three files: 1)
a .sig file, 2) the abstract.xml and 3) an .xml file named with the same name used for
the .sig file. In this case it is possible to visualize the data using the OT BioLab Open
menu window also selecting the .xml file format and choosing this file named as the
folder name.

o

abstract.xml files are generated by an old generation software called Acquisition
Software. It does not contain signals but all the information related to the signals
acquisition and provide links to one or more .sig files containing the data. When
opening one abstract file .xml it is possible to open one or more related signal files.
Several files .xml are generated by OT BioLab, but the open function is reserved to
abstract file created by Acquisition Software.

•

Brx: files generated by bruxoff and containing two EMG signals and one ECG signal.

•

Emg: files generated by µEMG or µEMG-S and containing a single EMG channel.

•

Frc: files generated by P-ForceMet and containing a single force channel.
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•

Bio: files generated by foremg and containing 4 EMG signals.

•

Txt: any text file containing data can be opened. To open it, OT BioLab require some details
regarding the format. For this reason a Text File Information window appears asking the user
to choose the decimal separator, the columns delimiter, the time column or at least the time
increment between subsequent lines. When all the information are inserted it is possible to
open the data.

All files, once opened, can be processed, manipulated and saved as .otb file.

Fig. 5.1.Pop-up Window that appears after saving the data if files are larger than 400 Mbytes.

5.2 Reviewing a signal
When opening a signal in Review Mode, OT BioLab displays a window similar to Fig.5.2. The tracks are
displayed in the same way as for Visualization Mode and the same options to manage the tracks are
available during the review (refer to Tracks options section).

Fig. 5.2.Screenshot during signal review showing an example of signals

Epochs
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In Review Mode, the signals are segmented in epochs. The epoch size can be defined by the user in
the Set Epoch field, in the toolbar (see Fig. 5.3). The epoch segmentation is necessary for several
processing plug-in. The signals can be selected in two ways: a left click on the Sensor name area
selects the entire signals, a drag through the desired epoch while pressing the left mouse button selects
a group of subsequent epochs.

Fig 5.3. Toolbars available in Review mode. From left to right: Edit toolbar, View toolbar, Subjects
toolbar and Set Epoch field.
Edit Toolbar
When more signals have been detected from a single sensor, they are grouped together by creating a
multiple track. In Review Mode, it is possible to group and ungroup signals as desired.
To ungroup signals select a multiple tracks and then press the minus green button on the Edit toolbar
or select Edit ->Ungroup Selected Tracks from the main menu bar. All the signals related to the original
sensor will be spitted in single tracks and moved under the last signal, in the bottom part of the OT
BioLab Review window. The name of single tracks will be assigned automatically by keeping the
enumeration of sensor channels.
To group together two or more signals select the desired signals and then press the plus green button
on the Edit toolbar or select Edit ->Group Selected Tracks from the main menu bar. The new multiple
track generated will be moved under the last signal, in the bottom part of the OT BioLab Review
window.
A given track can be deleted if desired, by selecting the track an pressing the Delete red button on the

Edit toolbar or selecting Edit ->Delete Selected Tracks from the main menu bar. Even if the track and
related signals are no longer displayed, in any case, the originally acquired data is preserved in the otb
file.
View Toolbar
The View toolbar (see Fig. 29) and the View menu include several options for the review of signals.
The available functions are:
•

Zoom In: increases the time view resolution by reducing the time window displayed. This
function it is also accessible by using the mouse scroll wheel together with the CTRL button.

•

Zoom Out: decreases the time view resolution by enlarging the time window displayed. This
function is also accessible by using the mouse scroll wheel together with the CTRL button.

•

Zoom to Selection: expand the time selection to fit the full screen.

•

Fit in Window: fits the entire signals to the full screen.
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•

Abstract: displays the information contained in the abstract file associated to the file opened.
The abstract will be open with a template generated in Excel.

•

Search for Abstract: search tool that allows to find a particular file by searching for abstracts
defined fields.

Subject Toolbar
Every signal acquired has to be stored together with subject details. For each subject it is possible to
create a record containing all the related data. The records are collected into a database. OT BioLab
give the user the possibility to manage different databases. This feature can be useful for privacy
aspects when more user use the same PC but they don’t want to share the subjects information.
By default one database is created by OT BioLab during installation in a folder managed by the O.S.
that the user can’t access directly. If the user do not need more than one database no operation are
required, automatically the default database is used and all the operation are performed on it.
Alternatively, under Subjects -> Manage Database it is possible to create a new database or select an
existing one. The database created by the user can be saved everywhere on the hard drive or external
memory devices with the desired filename. The extension, by default is .otdb. When a user database
is selected, OT BioLab keep memory of the database even when the software is restarted. In case file
.otd is removed, renamed or moved from the originally folder, by default the software switch to the
default database.
Subjects can be add to the database at the end of a recording, but it is also possible to insert new
subjects at any time. In particular, it is possible to add new subjects to the database or find and edit
the subjects record. Pressing the Add New Subject button in the Subject toolbar, the Subject Editor
window appears (see Fig. 5.4). All the information related to a subject can be typed, few of them are
compulsory, and then, pressing the OK button, the subject is added to the database.
In case some information related to one subject has to be modified, it is possible to search the subject
into the database, and then edit any desired field. The Find/Edit Subject button on the Subject toolbar
open the search window. Any parameter of a subject can be used to find its record into the database.
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Fig 5.4. Subject Editor window. It allows to add a new subject to the database or edit the
information related to an existing subject.

5.3 Signal Export
It is possible to export the signals acquired using OT BioLab to use them with different software (e.g.
Matlab, Excell, LabView...). Two are the methods to export the signals: “Selected signal(s)” or “Raw
data set”.
Using the option “Selected signal(s)” it is possible to export single or multiple traks, the result of a
processing or a subgroup of signals acquired. The export can be done using different file type: Binary,
CSV or Matlab files. Refer to the following paragraph for further details.
The “Raw data set” option allows to export the entire data set related to an acquisition. All the signals
originally acquired and for the entire acquisition time are exported together regardless of any applied
selection. The signals are exported in binary format.
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Export binary data
To use this option, during review, choose File->Export->Raw data setfrom the main menu bar. The
signals exported are saved as a .sig file. All the signals originally acquired and for the entire acquisition
time are exported together regardless of any applied selection.
The .sig file exported is a binary file structured as a number of row equal to the number of channels
acquired (i.e. number of rows occupied by sensors in the setup used during the acquisition) and a
number of columns that depends on the signals duration. The sample values are signed short in the
range -2048 ÷ 2047.
The following formula can be used to obtain the signals amplitude x at the input of the amplifier, given
each binary value N in the .sig file:
𝑥=𝑁

𝑉𝐴𝐷 1000
[𝑚𝑉]
2𝐴𝐷𝑅𝐸𝑆 𝐺𝑎𝑖𝑛

Where:
-‘VAD’ is theA/D converter input range in volts
-‘ADRES’ is the A/D converter resolution
-‘Gain’ is the gain used during the acquisition for the corresponding channel -‘1000’
allow to obtain the result in mV.
For example, when using EMG-USB, EMG-USB2 and MEBA, the A/D converter input range (VAD) is 5
V, the resolution (ADRES) is 12 bits and the Gain for each sensor can be find in the abstract file. Note
that the gain for AUX channels is 0.5 V/V since the inputs accept -5 ÷ 5V dynamics, but the A/D
converter input range is 0 ÷ 5V.
Export CSV data
Single channels, subgroups of acquired channels or processing results can be exported in CSV (comma
separated value) format. To export a .csv file select the desired tracks, choose File->Export->Selected

signal(s)->As CSV file... from the main menu toolbar. An error will occur if track with different sampling
frequency are selected to be exported together.
After the filename and the position has been selected the Export Settings window is displayed (see Fig.
5.5) where it is possible to select the type of header and decimal separator.
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Fig. 5.5.Export Settings window. It allows to set the exporting options.

The data is exported with signals amplitude estimated by OT BioLab representing the input signals at
the amplifier inputs, taking into account the gain used during the acquisition. By default the time
columns is added and the measurement units are indicated in the file header.
Note that it is not possible to export simultaneously different tracks if they has been acquired with
different sample frequencies.
Export Matlab files
Single channels, subgroups of acquired channels or processing results can be exported in as a Matlab
file. To export a .mat file select the desired tracks, choose File->Export->Selected signal(s)->As MAT

file... from the main menu toolbar. An error will occur if track with different sampling frequency are
selected to be exported together.
The .mat file exported can be open using Matlab. After the file has been open different variables will
be added to the workspace:
Data: an N-by-M matrix containing the exported data, N is the number of samples exported, M is the
number of channels exported;
Description: an M row vector containing the description of each channel exported; OTBFile: is
the path and filename of the .otb file where the data has been exported; SamplingFrequency:
is the value in Hz;
Time: is an N row vector containing the time instant for each sample of the exported data.
After the file loading the Matlab command plot(Time, Data(:,1)) will produce a graph of the first channel
exported versus the time.
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6 Signal Processing
OT BioLab allows to process any kind of signals managed by the software itself (refer to the File

Extension section). The processing tools are available in Review Mode. Processing functions are
accessible under the Processing menu.
There are processing plugins that can be only applied to single tracks and other processing can be
applied both to a single tracks or to a multiple tracks (refer to Track Options section).
All the processing tools do not change the recorded signals but generate new tracks under the last
existing track.

6.1 Amplitude
This processing tool use two standard amplitude estimators to generate two new single tracks
containing the results. The estimators are the Average Rectified Value (ARV) and the Root Mean Square
(RMS). The two tracks generated are added under the last existing track. In both cases a value for
every epoch is calculated and displayed as a point in the middle of each epoch. When the zoom is set
to display more epochs, the points are connected each other by displaying a line between each adjacent
points.
The estimation of ARV (AARV) is obtained for the epoch i using the following formula:
𝑁

1000
𝐴𝐴𝑅𝑉 (𝑖) =
∑|𝑥𝑘 | [𝜇𝑉]
𝑁
𝑘=1

Where:
-‘N’ is the number of samples per epoch.

-‘xk’ is the amplitude of the signal at the input of the amplifier in mV.
-‘1000’ let transform mV in uV.
The estimation of RMS (ARMS) is obtained for the epoch i using the following formula
1
𝐴𝑅𝑀𝑆 (𝑖) = 1000 √ 𝑥𝑘2 [𝜇𝑉]
𝑁
Where:
-‘N’ is the number of samples per epoch.
-‘xk’ is the amplitude of the signal at the input of the amplifier in mV.
-‘1000’ let transform mV in uV.
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6.2 Data Approximation
OT BioLab can provide different type of data approximation. In particular, three different tools are
grouped under the Data Approximation menu voice: average, linear and parabolic.
The three approximations can be applied at any kind of single track but they are intended to be applied
on processing results based on epochs: amplitude, frequency or conduction velocity estimation results.
When running a data approximation on a track, the software calculates the polynomial curve with the
desired grade best fitting the data set, minimizing the square error. The polynomial curve obtained is
superimposed to the track containing the data set and drown in red. The identified coefficients are
indicated in the sensor name.

6.3 Calibration
This processing plugin can be used to calibrate a signal acquired for example using a load cell to obtain
the trace directly expressed in the correct measurement unit and with the correct scale. Morover it is
possible to remove an offset to obtain the correct zero level.

6.4 User Code
This processing plugin give the user the possibility to write himself the code to process the acquired
data. The code has to be written using C# language and a series of examples are provided with OT
BioLab.
When running this plugin a new window, the Script Editor window, is displayed. On the left side of the
window the available scripts are listed with indication about the author, the creation and last
modification date, and description of the scripts. On the right side the code can be displayed or hided
the script code and here is possible to edit the code, save and run it.
Refer to Appendix A for further detail about the script editor and the provided scripts.

6.5 Conduction Velocity Estimation
This tool has been designed for the estimation of conduction velocity (CV) from single differential signals
detected by an electrode array. It is possible to use three different plug-ins to estimate the CV.
The first plug-in that appears in the dropdown menu under “CV Estimation” is named “Conduction
velocity Phase Delay (3 signals)” and it requires three single differential signals to estimate a CV value.
The three signals must be three single tracks selected by the user. The tracks can be grouped or
ungrouped. In case the user needs to use the “free selection” on tracks it is recommended to group
tracks to optimize the selection.
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The algorithm calculates two double differential signals from the three single differential signals and
then estimates the delay between the two signals obtained in a least square sense in the frequency
domain. For further details on the delay estimation refer to: McGill K.C., Dorfman L.J. High-resolution

alignment of sampled waveforms. IEEE Trans Biomed Eng, BME-31: 462–468, 1984.
Once the delay is estimated, CV is obtained dividing the distance between electrodes by the delay
obtained. The indication of the Inter Electrodic Distance (IED) is first of all searched in the sensor name
field of the signals, in case it is not found it is asked to the user.
The track containing the results is added under the last existing track. A value for every epoch is
calculated and displayed as a point in the middle of each epochs. When the zoom is set to display more
epochs, the points are connected each other by displaying a line between each adjacent points.
The second plug-in that it is implemented is based on a different algorithm and is named “Multichannel
Conduction Velocity”. With this plug-in it is possible to select and use different channels (three or more)
to estimate the CV. Also in this case the tracks can be groped or ungrouped. In case the user needs to
use the “free selection” on tracks it is recommended to group tracks to optimize the selection (see
Fig.6.1).

Fig. 6.1.Multichannel CV plugin used on 5 grouped signals.
This multichannel algorithm estimates the CV in the frequency domain. The algorithm is described in
the paper: “Assessment of average muscle fiber conduction velocity from surface EMG signals during

fatiguing dynamic contractions.” D.Farina et al, IEEE Trans Biomed Eng. 2004 Aug;51(8):1383-93andit
provides an estimation of the CV from a set of EMG signals in a time interval in which the mean square
error (mse) between aligned signals is minimized. The minimization of the mse function is performed
in the frequency domain, without limitation in the time resolution and with an iterative computationally
efficient procedure. The algorithm that is implemented in OT Biolab uses a rectangular window with an
amplitude of unity. This choice was adopted in order to minimize the computational time of the
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algorithm. The CV is calculated for epochs as for the previous algorithm. The track containing the results
is added under the last existing track. The value for every epoch is displayed as a point in the middle
of each epochs (see Fig. 32).
The third plug-in is named “Windowed conduction velocity” and it allows to calculate the CV at the
center of a free selection. The signal is windowed in time domain by a Gaussian function. The algorithm
used is the same of the Multichannel CV, so three or more signals can be selected. In this case it is
necessary to group the tracks in which the user calculates the CV. Using the free selection the plug-in
calculates the CV at the center of the selected time interval as reported in Fig. 6.2. When this plug-in
is selected a window will appear to select the desired sigma in milliseconds of the Gaussian window.
The calculated value is reported in a new track at the center of the selected interval (see Fig. 6.2).

Fig. 6.2.Example of a windowed CV calculated with a Gaussian function (sigma of 30 ms).

6.6 Differential
This processing tool can be applied to a multiple track or to a pair of single tracks. Simply it calculate,
sample by sample, the difference between signals.
When applied to a multiple track it make the difference between adjacent channels and retrieve a new
multiple track with N-1 signals when the starting multiple track has N signals. Typical application is the
use with multiple tracks containing EMG signals from an electrode array; the processing calculates the
single differential signals when applied to monopolar signals, or double differential signals when applied
to single differential signals. Be careful, this plugin when the number of signals selected is three or
more, it works only with grouped tracks.
In case a matrix is used for the calculation of differential signals, a window will appear to ask the user
to calculate differential data selecting the desired direction, horizontal or vertical. As result the
differential data are ordered with respect to rows or columns of the matrix.
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6.7 Envelope
Extract the envelope from a single track and normalize it with respect to the envelope maximum peak.
The tool has been designed for EMG signals, the resulting signal is obtained by rectifying the desired
signal and applying a II order Butterworth low pass filter with 5 Hz corner frequency to the rectified
signal.

6.8 FFT
The FFT can be estimated from single or multiple tracks on the desired number of epochs. After
selecting the track a window will appear (Fig. 6.3a) for selecting the number of samples that will be
used to obtain an averaged FFT to reduce the noise in the estimated power spectrum. A minimum of
256 samples for the averaged FFT is required. The maximum number of samples is equal to the length
of the data. From this menu the user can select the window functionsto apply to the time domain data
forestimating the FFT (rectangular, hanning, hamming, blackman). Samples used to obtain the
averaged FFT can be overlapped (50 % of overlap - Welch’s method) or no overlapped (Barlett’s
method) selecting the options that appears on the bottom-right of the window menu. After selecting
these options a new window will display the result of the algorithm (Fig. 6.3b). Details about the FFT
algorithm can be found at http://sourceforge.net/projects/kissfft. After the FFT has been estimated,
keeping the left mouse button pressed a rectangular window can be drawn to indicate the area that
the user want to zoom in. When a right click on the FFT window is done a menu appears close to the
cursor. The options given by this menu allows to copy, save or print the graph, to show the graph
values at the cursor position, to change manually the X and Y axis limits and to manage the zoom.

Fig. 6.3.Example of an FFT spectrum obtained from an EMG channel. In Fig. 6.3a the window menu
for selecting number of samples. In Fig.6.3b an FFT spectrum obtained averaging 1024 samples is
shown.
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6.9 Filtering
This processing tool can be applied both to single tracks and multiple tracks. When running it, a request
of filter type and corner frequencies is displayed. It is possible to choose between different type of
filters:
•

Low Pass.

•

High Pass.

•

Band Pass.

•

Stop Band.

Moreover, the corner frequencies are differently asked depending on the filter type selected.
The signals generated by the filtering process are added as single or multiple track in the review
window leaving unaltered the starting signals. All filter types are II order Butterworth filters.

6.10 Frequency
This processing tool uses two standard frequency estimators to generate two new single tracks
containing the results. The estimators are the Mean Frequency (MNF) and Median Frequency (MDF).
The two tracks generated are added under the last existing track. In both cases a value for every
epoch is calculated and displayed as a point in the middle of each epochs. When the zoom is set to
display more epochs, the points are connected each other by displaying a line between each adjacent
points. The estimation of MNF (fMNF) is obtained for the epoch i using the following formula:

𝑓𝑀𝑁𝐹 (𝑖) =

∑𝑛𝑘=0 𝐼𝑘 ∙ 𝑓𝑘
[𝐻𝑧]
∑𝑛𝑘=0 𝐼𝑘

Where:
-‘n’ is the number of frequency bins in the spectrum.
-‘fk’ is the frequency of the spectrum at bin k of n.
-Ik is the Intensity of spectrum at bin k of n.
The estimation of MDF (fMDF) is obtained bycomparing the total signal spectrum intensity divided by
two with the cumulative intensity (i.e. all the intensity values for frequencies lower and including the
focal intensity). The lowest frequency retrieving the cumulative intensity bigger than the half total
intensity is fMDF.

6.11 IZ Maps
An automatic algorithm has been implemented in OTBiolab to localize automatically the innervations
zones (IZs) of a muscle.
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The algorithm is based on the calculation of the phase inversion of differential EMG signals. This plugin
works only with Monopolar signals acquired by 64 channels matrixes. The matrixes implemented are
the ELSCH064RS3 10 mm IED, ELSCH064NM2 10 mm IED, ELSCH064NM3 8 mm IED.
The phase inversion is calculated using a cross-correlation as described in the paper: “Accuracy of the

three techniques for automatically estimating innervations zone location ”, Travis W.Beck, Jason
M.DeFreitas , Matt S. Stock, Computer Methods and Programs in Biomedicine 105 (2012) 13-21.
The value of the cross-correlation is normalized between 0 and 1. Finally this value is used to plot on
a 2D map the innervations zone (see Fig.36).
In order to localize the IZs in a proper way, the matrixes must be positioned with a preferred direction
along the direction of the muscle fibers. The directions used for these matrixes are, respectively: the
horizontal direction for the 8x8 channels ELSCH064NM3 matrix, the vertical direction for the
ELSCH064RS3 matrix and the horizontal direction for the ELSCH064NM2 matrix (see Fig.6.4).
In Fig. 6.5 are reported some examples for the localization of the IZ of the biceps muscle for all the
three matrixes.

Fig. 6.4.Directions that must be used to place the matrixes with respect to the directions of the
muscle fibers for localizing the IZs zone with the OTBiolab plugin IZ Maps.
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Fig. 6.5.Three examples of the IZs localization with three different matrixes. The red zones of the
maps represents the IZ zones of the brachii muscle.

6.12 Maps
Maps plugin allows show in a 2D plot the matrix signals of 64 electrodes or 16 electrodes with different
colour scales. After selecting 64 signals it is possible to choose the electrode matrix used for the data
acquisition (see Fig. 6.6).
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